Subscribe to our 0800-DEVOPS Newsletter

Get in touch

Contact us for all inquiries regarding services and general information






Get in touch

Contact us for all inquiries regarding services and general information






Use the form below to apply for course





Get in touch

Contact us for all inquiries regarding services and general information






Blog

Q&A: Keep Your IBM API Connect Running And Supported

Here is what you need to know if you are considering upgrading your API Connect.
If you have more questions related to your specific need, feel free to contact us, our API Connect experts are here to help!

 

Q: What are currently supported versions of API Connect?
Currently, there are two Long Term Support versions of API Connect that gets fixes:
APIC v5.0.8.x – released September 08, 2017
APIC v2018.4.1.x – released November 15, 2018

Q: What to do if your APIC is at version v5.0.8.6 or below?
In-place upgrade to the 5.0.8.7 iFix 4 or later. Version 5.0.8.x is only version from v5 branch that receives fixes.

Q: What about DataPower version?
Suggested version to upgrade to is 2018.4.1.10 or later. This version of DataPower firmware can be configured to work in v5 or v2018 mode. All older firmware versions are now out of support. Action: If you are still using firmware 7.6, 7.5 or older you should upgrade DataPower to the latest firmware version.

Q: Should I migrate to APIC v2018.4.1.x?
Currently, there is no end of support announced for APIC V5. But it is strongly suggested that migration starts in 2020.

Q: What are the benefits of migrating to APIC v2018.4.1.x?
APIC v2018 brings major benefits in two areas:

New microservice architecture
Allows better scalability
Hybrid deployments are possible and easy compared to V5
Better support for Cloud-native development and DevOps
New API Gateway object in DataPower
Build for performance (about 10x performance improvement can be expected comparing to v5)
Improved availability. DataPower doesn’t rely on Management component for availability. It self-heals using quorum persistence.

Still not sure about when and how to start upgrading your IBM Middleware? Contact CROZ for help, we have vast experience in helping companies across Europe keeping their IBM Middleware running and supported in the most effective and optimal way!

CONTACT

Get in touch

Contact us